Thứ Hai, 06/07/2009 - 06:46

Thủ thuật giúp cài đặt mọi plug-in trên Firefox 3.5

Dân trí Một trong những lý do Firefox được đánh giá cao hơn các trình duyệt khác đó là nó có hệ thống plug-in giúp ích rất nhiều cho người dùng. Tuy nhiên, với Firefox 3.5 mới ra mắt, còn rất ít plug-in tương thích.

Bài viết sau đây sẽ giúp bạn cài đặt mọi plug-in trên Firefox 3.5.

 

Như chúng ta đều đã biết, Firefox là trình duyệt web mã nguồn mở, do vậy, các plug-in được chính những người dùng có trình độ viết ra sẽ cực kỳ hữu ích cho những người dùng khác. Đây cũng chính là một trong những lý do Firefox rất được yêu thích.

 

Tuy nhiên, khi một phiên bản mới ra mắt, các plug-in được viết dành cho các phiên bản trước đó lại gặp rắc rối và không thể cài đặt trên phiên bản mới. Trong trường hợp này, người dùng bình thường đành phải chờ tác giả của các plug-in này cập nhật plug-in mới cho Firefox. Điều này đôi khi rất bất tiện nếu bạn đã quen sử dụng các plug-in đó trên Firefox.

 

Trong trường hợp bạn đã quá quen thuộc với 1 vài plug-in nào đó, nhưng nó vẫn chưa được cập nhật cho Firefox phiên bản mới nhất (3.5), điều này đồng nghĩa với việc hoặc là bạn sử dụng Firefox không có plug-in đó, hoặc là bạn vẫn phải sử dụng Firefox 3.0 và chờ cho đến khi plug-in đó ra mắt phiên bản dành cho 3.5. Tuy nhiên, chỉ với thủ thuật nhỏ sau đây, bạn có thể cài đặt bất cứ plug-in cũ nào trên Firefox 3.5 mà không gặp bất cứ vấn đề gì.
 

- Đầu tiên, bạn mở cửa sổ Firefox, gõ about:config trên thanh địa chỉ và nhấn Enter. Một thông điệp hiện ra, bạn click vào nút “I’ll be careful, I promise!” để tiếp tục.
 


- Tiếp theo, bạn click chuột phải ở bất cứ đâu tại khung bên dưới, chọn New -> Boolean.
 



 

- Một hộp thoại hiện ra, điền extensions.checkCompatibility, nhấn OK và thiết lập giá trị false ở khung hộp thoại tiếp theo.
 



 

- Thực hiện tương tự bước trên, click chuột phải, chọn New -> Boolean và tạo 1 khóa khác mang tên extensions.checkUpdateSecurity, cũng thiết lập giá trị false cho khóa này.

 

- Cuối cùng, khởi động lại Firefox để thiết lập có giá trị.

 

Và bây giờ, tất cả các plug-in cũ trước đây bạn từng sử dụng trên Firefox 3.0, thậm chí là Firefox 2.0 đều có thể cài đặt bình thường trên Firefox 3.5. Và bạn có thể yên tâm sử dụng Firefox 3.5 hoàn toàn quen thuộc với những plug-in đã cài đặt ở các phiên bản trước đó.

 

Hy vọng, bài viết sẽ hữu ích cho bạn.

 

Phạm Thế Quang Huy